首页 > 浏览文章 > lamp|lnmp|lnamp/下安装exif

lamp|lnmp|lnamp/下安装exif

有些php程序需求exif扩展,但是服务器不支持exif,安装方法如下
-----------------------------------------------------------------------------
比如php的安装目录为:/root/lanmp/php-5.2.17
则执行:
  1. cd /root/lanmp/php-5.2.17/ext/exif/
复制代码

再执行
  1. [root@IPV6 exif]# /www/wdlinux/php/bin/phpize
复制代码


会返回如下信息:

  1. [root@IPV6 exif]# /www/wdlinux/php/bin/phpize
  2. Configuring for:
  3. PHP Api Version:         20041225
  4. Zend Module Api No:      20060613
  5. Zend Extension Api No:   220060519
复制代码


再执行以下命令:

  1. [root@IPV6 exif]#./configure --with-php-config=/www/wdlinux/php/bin/php-config
复制代码

  1. [root@IPV6 exif]# make && make install
复制代码


执行完返回:

Build complete.
Don't forget to run 'make test'.

Installing shared extensions:     /www/wdlinux/php-5.2.17/lib/php/extensions/no-debug-non-zts-20060613/

表示已经成功,再修改/www/wdlinux/etc/php.ini

查找:extension = 再最后一个extension= 后面添加上
  1. extension = "exif.so"
复制代码


保存,执行
  1. service httpd restart
复制代码

重启。


同理,php_mbstring也要这么安装,因为exif扩展依赖于此。




其他链接

意见箱 © 个站商店 2016 v0.98 星球彦 | 访客数:161969